Cisco router ipsec 配置

来自Qno Wiki
跳转到: 导航搜索

 Cisco router ipsec configure

目录

Router(config)


Router>en (進入特權模式)

Router#configure terminal (進入配置模式)

Router(config)# crypto isakmp policy 1 (配置IKE 策略1) Cisco router ipsec 配置o1.jpg

Router(config-isakmp)# hash md5 (採用md5認證演算法) Cisco router ipsec 配置06.jpg

Router(config-isakmp)# authentication pre−share (驗證方式使用pre−share)

Router(config-isakmp)# exit

Router(config)# crypto isakmp key cisco123 address 111.251.184.248 (設定共用密鑰cisco123以及對方的外部接口IP) Cisco router ipsec 配置07.jpg

Router(config)# crypto ipsec transform−set rtpset esp−des esp−md5−hmac (設置AH散列算法為md5 ESP加密算法為DES) Cisco router ipsec 配置08.jpg

Router(cfg-crypto-trans)#exit

Router(config)# crypto map rtp 1 ipsec−isakmp (定義crypto map)

Router(config-crypto-map)# set peer 111.251.184.248 (設置隧道遠端IP地址)

Router(config-crypto-map)# set transform−set rtpset (設置隧道AH及ESP)

Router(config-crypto-map)# match address 115 (符合access 115 做VPN)

Router(config-crypto-map)# exit

Router(config)# interface FastEthernet0/0 (進入外部接口)

Router(config-if)# ip address 59.120.186.111 255.255.255.0 (配置IP)

Router(config-if)# ip nat outside (定義此接口為NAT outside)

Router(config-if)# crypto map rtp (將rtp貼在外部接口)

Router(config-if)# exit

Router(config)# interface FastEthernet0/1 (進入內部接口)

Router(config)# ip address 10.10.10.10 255.255.255.0 (配置IP)

Router(config)# ip nat inside (定義此接口為NAT inside)

Router(config)# ip nat inside source route−map nonat interface FastEthernet0/0 overload

Router(config)# ip route 0.0.0.0 0.0.0.0 59.120.186.254 (設定default route)

Router(config)# access−list 110 deny ip 10.10.10.0 0.0.0.255 192.168.1.0 0.0.0.255 (deny 自己內網IP到對方內網IP(不轉NAT))

Router(config)# access−list 110 permit ip 10.10.10.0 0.0.0.255 any (permit內網IP到所有地方的都轉NAT)

Router(config)# access−list 115 permit ip 10.10.10.0 0.0.0.255 192.168.1.0 0.0.0.255 (定義要做VPN的網段)

Router(config)# route−map nonat permit 10

Router(config)# match ip address 110

设定

网关对网关的设定


Cisco router ipsec 配置01.jpg

本机VPN群组设定


Cisco router ipsec 配置02.jpg

远程VPN群组设定


Cisco router ipsec 配置03.jpg

IPSec设定


Cisco router ipsec 配置04.jpg

高级设定


Cisco router ipsec 配置05.jpg

个人工具
名字空间
操作
导航
分类
[×] AP/AC
[×] DHCP
[×] GRE
Log
[×] NetBase
QoS
[×] QTV
[×] QWH
[×] Switch
USB
VPN
工具箱